Lost in space
Banned
💻 Oldtimer
Joined
Dec 1, 2002
Messages
2,725
Best answers
0
Alright, I have started my first map I actually plan on releasing.
Progress is begining. It's still got a long way to go, but I'm going to keep you guys updated with screenshots as I finish it. Don't expect too much from me, but I need some work out there so I can call myself a mapper...something I've wanted to do for a long time. :D
Here's screenshot round one. :)







Critz? (Please be gentle :p)
 
New Member
✔️ HL Verified
💻 Oldtimer
Joined
Oct 27, 2002
Messages
1,185
Best answers
0
although i dont like terrain generators, i do know how to do terrain like that but it would take me forever...i think u should learn to never use terrain generator unless u can make what the terrain genertor can, this will build skill beyond all others. anyway, why do those textures look so horrible?
 
Lost in space
Banned
💻 Oldtimer
Joined
Dec 1, 2002
Messages
2,725
Best answers
0
You mean the dirt ground texture?
I don't get what is wrong with it. I edited it to make it darker and lighter, but when you look at it in-game it changes brightness really sharply depending on what angle you look at it.

They look pixelated because I took the screenshots in 640X480 rez, software mode...my computer sucks.

And I know you shouldn't use terrain generators...I'm kinda ashamed of it, but I am horrible at making organic outside maps. If I didn't use one, the surface of the ground would be all flat.
 
Lost in space
Banned
Joined
Dec 30, 2002
Messages
76
Best answers
0
Originally posted by DragonDude
Alright, I have started my first map I actually plan on releasing.
Progress is begining. It's still got a long way to go, but I'm going to keep you guys updated with screenshots as I finish it. Don't expect too much from me, but I need some work out there so I can call myself a mapper...something I've wanted to do for a long time. :D
Here's screenshot round one. :)







Critz? (Please be gentle :p)

is there on the pictures bad textures or u choos a bad videomode ?
 

Bolteh2

B
Guest
hmm, not every one has 3d card :p so ..


anyway, compile with light (or make sure that there are no leaks)
 
Lost in space
Banned
💻 Oldtimer
Joined
Dec 1, 2002
Messages
2,725
Best answers
0
The map had some major leakage... I fixed all but one which I cannot find but have narrowed down via Cordon Bounds. But still, the map is covered in light even with light entities and the leaking area bounded off. Why is this? Shouldn't the light entities be working now?
 
ESF Head Team Mapper
👑 Administrator
🌠 Staff
✔️ HL Verified
🚂 Steam Linked
🍂 Regular
Joined
Dec 25, 2001
Messages
3,619
Best answers
0
#1 terrain generators sux!
#2 creating realistic/good looking outside terrain isnt very hard. just use 2 triangle brushes instead of one block brush and edit the vertexes of the triangle brushes. it just takes some time, but it looks a way better then terrain generators. if you have any problems with triangle brushes, contact me on aim or icq sunday evening when im back. ill maybe make a tutorial about triangle brushes soon ...
 
Lost in space
Banned
💻 Oldtimer
Joined
Dec 1, 2002
Messages
2,725
Best answers
0
I have remodeled the map alot now, I'll have pics pretty soon, as soon as I fix the problem with light being everywhere. (There's no leak! I fixed it! But there is no bouncing light!)
I deleted the generated floor and made it flat, and added a pillbox thingy around it which you can go inside and go under the big tower arena and fight there in a big open space.
The only place I got generated terrain now is on the outside of that big tower arena. Need that tutorial DJ, I suck at making cliffs and stuff. :p

*EDIT* - I could take pics from Worldcraft, they would look much better because of my crappy computer, and there wouldn't be a light problem...you guys want me to do that?
 
New Member
Joined
Mar 9, 2003
Messages
96
Best answers
0
Looks neat I just think you should spend more time untill you show us some pics :yes:
 
Lost in space
Banned
💻 Oldtimer
Joined
Dec 1, 2002
Messages
2,725
Best answers
0
I have done alot now, the map is basically ready to be released, i just need help with the lighting!
There are no leaks, and there are light entites, but when I compile and run the map there is light everywhere, as if there was a leak!
I have checked many times, there is NO leak! I don't get it!
 
New Member
Joined
Mar 9, 2003
Messages
96
Best answers
0
Doh I think you are looking at a past map. Try to rename it and compile it. If it works then change it back to the name you wanted.
 
Lost in space
Banned
💻 Oldtimer
Joined
Dec 1, 2002
Messages
2,725
Best answers
0
Nope, it's the right map...it's my current version with no leaks. I just ran it compiled it again and there is still light everywhere.
::begins pulling out hair::

*EDIT* - Maybe this could be a problem?
When I compile I run CSG, then BSP, then VIS, then LIGHT (Thats RAD I think), in that order.
Could this order be the problem?

*SECOND EDIT* - Here is the tail end of my compile...there are quite a few errors, but I don't know what any of them are or how to fix them...

BSP generation successful, writing portal file 'c:\sierra\HALF-L~2\esf\maps\moon_e1.prt'
16.60 seconds elapsed

----- END hlbsp -----




** Executing...
** Command: C:\PROGRA~1\ZHLT\hlvis.exe
** Parameters: -texdata 8192 -high -fast c:\sierra\HALF-L~2\esf\maps\moon_e1

g_fastvis = true
hlvis v2.5.3 rel (May 2 2001)
Based on Valve's version, modified with permission.
Submit detailed bug reports to ([email protected])
----- BEGIN hlvis -----
Command line: C:\PROGRA~1\ZHLT\hlvis.exe -texdata 8192 -high -fast c:\sierra\HALF-L~2\esf\maps\moon_e1

-= Current hlvis Settings =-
Name | Setting | Default
-------------------|-----------|-------------------------
threads [ 1 ] [ Varies ]
verbose [ off ] [ off ]
log [ on ] [ on ]
developer [ 0 ] [ 0 ]
chart [ off ] [ off ]
estimate [ off ] [ off ]
max texture memory [ 8388608 ] [ 4194304 ]
priority [ High ] [ Normal ]

fast vis [ on ] [ off ]
full vis [ off ] [ off ]


713 portalleafs
2338 numportals
BasePortalVis:
10%...20%...30%...40%...50%...60%...70%...80%...90%... (25.11 seconds)
Warning: Leaf portals saw into leaf
Problem at portal between leaves 412 and 411:
(-510.000 729.000 183.000)
(-510.000 691.000 284.000)
(-510.000 691.000 284.000)
(-707.678 679.620 174.647)

Warning: Leaf portals saw into leaf
Problem at portal between leaves 463 and 464:
(-1257.830 809.887 -256.000)
(-1379.000 786.000 -359.000)
(-1379.001 786.000 -359.000)
(-1379.000 804.000 -256.000)

average leafs visible: 329
g_visdatasize:59274 compressed from 64170
25.74 seconds elapsed

----- END hlvis -----




** Executing...
** Command: C:\PROGRA~1\ZHLT\hlrad.exe
** Parameters: -extra -texdata 8192 -high -chop 128 c:\sierra\HALF-L~2\esf\maps\moon_e1


ERROR: Could not open logfile c:\sierra\HALF-L~2\esf\maps\moon_e1

.loghlrad v2.5.3 rel (May 2 2001)
Based on Valve's version, modified with permission.
Submit detailed bug reports to ([email protected])
----- BEGIN hlrad -----
Command line: C:\PROGRA~1\ZHLT\hlrad.exe -extra -texdata 8192 -high -chop 128 c:\sierra\HALF-L~2\esf\maps\moon_e1



-= Current hlrad Settings =-
Name | Setting | Default
--------------------|---------------------|-------------------------
threads [ 1 ] [ Varies ]
verbose [ off ] [ off ]
log [ on ] [ on ]
developer [ 0 ] [ 0 ]
chart [ off ] [ off ]
estimate [ off ] [ off ]
max texture memory [ 8388608 ] [ 4194304 ]
priority [ High ] [ Normal ]

vismatrix algorithm [ Original ] [ Original ]
oversampling (-extra)[ on ] [ off ]
bounces [ 1 ] [ 1 ]
ambient light [ 0.000 0.000 0.000 ] [ 0.000 0.000 0.000 ]
maximum light [ 256.000 ] [ 256.000 ]
circus mode [ off ] [ off ]

smoothing threshold [ 50.000 ] [ 50.000 ]
direct threshold [ 25.000 ] [ 25.000 ]
direct light scale [ 2.000 ] [ 2.000 ]
coring threshold [ 1.000 ] [ 1.000 ]
patch interpolation [ on ] [ on ]

texscale [ on ] [ on ]
patch subdividing [ on ] [ on ]
chop value [ 128.000 ] [ 64.000 ]
texchop value [ 32.000 ] [ 32.000 ]

global fade [ 1.000 ] [ 1.000 ]
global falloff [ 2 ] [ 2 ]
global light scale [ 1.000 ] [ 1.000 ]
global gamma amount [ 0.500 ] [ 0.500 ]
global sky diffusion [ 1.000 ] [ 1.000 ]

opaque entities [ on ] [ on ]
sky lighting fix [ on ] [ on ]
incremental [ off ] [ off ]
dump [ off ] [ off ]


Error: Error opening c:\sierra\HALF-L~2\esf\maps\moon_e1

.bsp: Invalid argument

** Executing...
** Command: Copy file
** Parameters: "c:\sierra\half-life\esf\maps\moon_e1.bsp" "C:\Sierra\Half-Life\esf\maps\moon_e1.bsp"

* Could not execute the command:
Copy file "c:\sierra\half-life\esf\maps\moon_e1.bsp" "C:\Sierra\Half-Life\esf\maps\moon_e1.bsp"
* Windows gave the error message:
"Access is denied."

** Executing...
** Command: Copy file
** Parameters: "c:\sierra\half-life\esf\maps\moon_e1.pts" "C:\Sierra\Half-Life\esf\maps\moon_e1.pts"

* Could not execute the command:
Copy file "c:\sierra\half-life\esf\maps\moon_e1.pts" "C:\Sierra\Half-Life\esf\maps\moon_e1.pts"
* Windows gave the error message:
"Access is denied."

** Executing...
** Command: Change directory
** Parameters: C:\Sierra\Half-Life\valve


* Could not execute the command:
Change directory C:\Sierra\Half-Life\valve

* Windows gave the error message:
"Access is denied."

** Executing...
** Command: C:\Sierra\HALF-L~2\hl.exe
** Parameters: -particles 20000 -dev -console -game esf +deathmatch 1 +map moon_e1
 
New Member
Joined
Mar 24, 2003
Messages
69
Best answers
0
Try compiling your map using a full VIS rather than a fast VIS. I think that might be the lighting problem you are having.
 
New Member
Joined
Jan 21, 2003
Messages
290
Best answers
0
i took this from gamedesign.net:

It's not so simple as finding the single offending "leafportal" brush. As your map increases in size or simply changes brushes that generate no errors can become causes of leafportal errors. Worse is that subsequent compiles of the unchanged map may produce more or fewer leafportal errors, and this lack of consistency makes finding the error even more maddening.

Often the worst offenders are brushes with many faces sharing the same vertex (like a spike or a skewed brush with a mitered corner).

Advice often given is to "simplify". While this is useful advice up to a point I suppose, tracking down specific troublesome brushes as they relate to their environment (your map) is the real key (good luck). If you do find them, I've recently discovered that making them and the brushes they adjoin detail brushes may correct the problem, as will making them brush entities like func_walls. (Since this is a vis error, this makes sense when you think about it).
 
Lost in space
Banned
💻 Oldtimer
Joined
Dec 1, 2002
Messages
2,725
Best answers
0
Ok I think I have an idea where the problem is, but when I delete it the map is going to look stupid in that spot.
I'll have to fix it when I get home...
 
New Member
Joined
Nov 29, 2002
Messages
99
Best answers
0
maybe delting that / fixing it
would be a nice occasion to learn
about the triangular brushes
 
Lost in space
Banned
💻 Oldtimer
Joined
Dec 1, 2002
Messages
2,725
Best answers
0
I know how to use the spike brushes, but it looks like crap whenever I try to make something look natural...I've got to learn how to make them look organic before I make a map that requires many of them again. :rolleyes:

*EDIT* - Damn, I deleted the part where I was sure it was causing the light problem, and it didn't fix it...
There isn't any way you can check to know for sure which leaf is causing the problem? :scared:
 
New Member
💻 Oldtimer
Joined
Nov 22, 2002
Messages
2,347
Best answers
0
If I understand you correctly you see all light, with or without light_environment? If that entity isn't in then it will light up everything and give no shadow.
 
New Member
Joined
Jan 21, 2003
Messages
290
Best answers
0
well like what it said in my last post, its a hard problem to fix.......good luck :p
 

Users who are viewing this thread

Top