To new people: If you have a problem chances are it's been answered here.

Lost in space
Banned
💻 Oldtimer
Joined
Sep 20, 2003
Messages
3,211
Best answers
0
Ok, I've been seeing a lot of the same questions asked by many different people. So here is a new help thread I feel should be addressed.

First off. My guess is this thread is going to be very long. So just use ctrl+F to search for what you're looking for in this thread.

Installation problems

First off, let me address that you need a legit copy of either Half-life (Recommended) Counter-Strike, or Day of Defeat.

ESF will not work for anything other then those three games. That includes Counter strike: Source, DoD: Source, Half-LIfe: Source, Half-Life 2 or anything like that. ONLY those three games. (Again half-life 1 is recomended)
(Credits to Grega)

You also need Steam. You can get steam at www.steampowered.com

If you have Half-life, you're golden. Just download and install steam, let it update, go to "Play games" You will see a bunch of grayed out games (Half Life, Day of Defeat, Counter-Strike, etc) Click on Half-Life and it will tell you that you need to download it. Go ahead and say yes.

If you have CS or DoD then do the same thing. Install it, install steam, go to play games and click on Half-Life and it will download for you. (legally of course)

Then you intall ESF1.2.x into your HL directory: c:/program files/valve/steam/steamapps/your user name/Half-Life

Don't want to buy half-life? Too lazy to get it. What's the only other alternative. DOWNLOADING! Sure you can download half-life. But you can't play ESF if you do. (Unless you have either CS or DoD, and are dling HL from steam.

YOU NEED HALF-LIFE 1!!!!!!!!! NOT HALF-LIFE 2. ESF WILL NOT WORK ON HALF-LIFE 2!!!
What about WON?

WON is dead. Don't use it. It died a long time ago. you need STEAM! which again can be found at www.steampowered.com

Problems with Steam
I have noticed that many many many people are in the help thread making threads about thier "Steam Ticket" expiring. Here are a few reasons as to why this may be happening.

1. You share your cd-key with someone (or the other way around) which causes 2 or more of the same user on at once.
2. You use your username for a dedicated server and to play esf at the same time.
3. You don't have a legit copy of half-life and somehow know the user name and password of someone who uploaded HL and etc. to the internet.

How to solve the above problem.

1. Contact steam and tell them about it.
2. Search the steam forums.
3. Get a legit copy of half-life.
4. If you have a legit copy of half-life, ask valve to give you a new CD-key ($10 for a copy of HL over 90 days old, free for under 90 days)


Ok, well I have the game I just don't know how to play. Can you help me?

Sure we can. http://games.saix.net/guides/esf/right.htm
That is the ESF manual. It tells you how to play. (also give you STEAM instructions as to how to install ESF).

But Fire Phoneix, I hate reading.

Not a problem, Chakra-X was kind enough to provide a flash tutorial on how to play. It cuts down on the reading. It can be found here.

http://esf-world.com/main.php?content=12xflashtut&lang=de

I can't join a server!

Ok, there are a couple reasons for why you can't join a server.

1. If it says models/evolution/Fusion.Patara.mdl then you tried to connect to an EVM server. In that case if you wanted to join that server, you would need EVM. That is found at www.corona-bytes.net I also believe you can find it at www.esf-world.com

2. If it says something like "Your client.dll differs from the server" it means that you have a different version of ESF then the server. Chances are you have 1.2.1 or 1.2 or 1.2.2 and they have 1.2.3. Or maybe you have 1.2.3 and they have 1.1 or 1.2.1 etc.

3. If it tells you "Can't load library halflife/esf/dlls/client.dll" or something like that and you are using STEAM. Than you nead the fmod.dll. If can be downloaded here http://www.esf-world.com/main.php?c...o&file_id=21035
(Thank you Grega)

A common problem that newbies have like "i can't install esf" (which is fixed by running hl once before installnig ethier 1.2.2 or 1.2.3 full installers/patches)

also with "your client dll differs" , 1.2.3 is no client dll change (just note you will need to install 1.2.2 before 1.2.3 to fix this) 1.2.3 is just map fixes for the gero skybox glitch and adds the new map esf_arrival. However this is only for the people that use the patches to update esf and no need to worry for people who have 1.2.3 full installer.

(Credits to Saiyan Overlord)

Another problem that has been popping up lately is the meleesounds.sc problems that some people get here and there.

Fix: If your game starts up and the you receive an error of a missing meleesounds.sc, then create a new folder called events in your ESF directory. Then create a blank text-file in notepad and save it as "meleesounds.sc", with the quotes and save it into your events directory. If you don't use the quotes, it will save as a regular text file, and the error will remain..
(Credits to Saiyan Overlord)

Why does the game crash?!? My computer is more then capable for running ESF.

Good question. Why does it crash. No one knows. That's what these patches have been mostly for. No one can figure out the reason as to why ESF crashes. But here are some tips.

1. Official ESF servers crash very often.
2. Listenservers and dedicated servers made by people like you and me, don't crash as often.
3. Using bots crashes your server more often then if you didn't have bots.
4. If you are running in software mode and not OpenGL or D3D you will have issuses with your GFX and it can cause crashes.

Combos? What are they? What's the key imput to do a combo?

Don't ask on the ESF Forum. No one will tell you, and your thread WILL BE closed. If you want to know. Ask someone in ESF or IM someone on the forum in hopes that they tell you.

I can't see anything. My screen flashes and nothing works or looks right.

Go into your online settings, and in the video mode, switch from Software to OpenGL. If your video card does not support OpengGL then switch to Direct 3D. Also try updating your drivers. Go to the site of your video card and check to update your drivers.

NSIS Error

Do you download ESF and get an install error that says "The installer you are trying to run is corrupted or incomplete. This could be the result of a damaged disk, a failed download, or a virus.
You may want to contact the author of this Installer to obtain a new copy.

It may be possible to skip this check using the /NCRC command line switch.(NOT RECOMMENDED)"

Chances are
1. You didn't download the entire file
2. It's corrupt
3. Or you have a virus in your computer.

Fix: Scan your computer for virus' and try downloading from another site that hosts the file.

Can you go beyond the first transformation in the current ESF game?

No, right now you can only go 1 level beyond normal. 1.3 will have further transformations.

Oh cool! So when will 1.3 be out?

When it's done. Understand that the people that create this mod, do it on their free time. It's like a hobby for them. Usually it takes about a year for ESF to come out with a new version.

I hope I didn't miss anything. If I did please feel free to ask it here and I will be sure to Edit my post. Also use other major help threads in this section. Here are some links to other help threads.

Big Mega thread of helping: http://www.forum.esforces.com/showthread.php?t=33312

FPS/PING/LAG Help: http://www.forum.esforces.com/showthread.php?t=36638

Also try looking in the Help section. Things are stickied if they are important.

Any other questions just ask here. If it has not already been answered I will edit this thread for new users.

-Fire Phoenix-
 
Freelance Mappzor
✔️ HL Verified
🚂 Steam Linked
💻 Oldtimer
Joined
Nov 21, 2003
Messages
17,065
Best answers
0
Fire Phoenix said:
I can't join a server!

Ok, there are a couple reasons for why you can't join a server.

1. If it says models/evolution/Fusion.Patara.mdl then you tried to connect to an EVM server. In that case if you wanted to join that server, you would need EVM. That is found at www.corona-bytes.net I also believe you can find it at www.esf-world.com

2. If it says something like "Your client.dll differs from the server" it means that you have a different version of ESF then the server. Chances are you have 1.2.1 or 1.2 or 1.2.2 and they have 1.2.3. Or maybe you have 1.2.3 and they have 1.1 or 1.2.1 etc.
3. If it tells you "Can't load library halflife/esf/dlls/client.dll" or something like that and you are using STEAM. Than you nead the fmod.dll. If can be downloaded here http://www.esf-world.com/main.php?content=fileinfo&file_id=21035
 
New Member
Joined
Jul 24, 2005
Messages
3
Best answers
0
someone help me plz i get to the part you click on the install button but it does not let me click it so i can't install it i have half life 2 is tht why i can not click it plz help
 
New Member
💻 Oldtimer
Joined
Mar 6, 2003
Messages
3,999
Best answers
0
metal slug said:
someone help me plz i get to the part you click on the install button but it does not let me click it so i can't install it i have half life 2 is tht why i can not click it plz help
You need Half-Life 1.
You need Steam.
You need to run Half-Life 1 through Steam before you try to install ESF.
 
Lost in space
Banned
💻 Oldtimer
Joined
Sep 20, 2003
Messages
3,211
Best answers
0
metal slug said:
someone help me plz i get to the part you click on the install button but it does not let me click it so i can't install it i have half life 2 is tht why i can not click it plz help
This makes me sad. I made this so you would read it. Unless you didn't know you needed half life. I'll have to make sure that's easily seen.

::EDIT::

Ok I edited to make it clear that you need Half-Life 1. Not Half-Life 2.
 
Freelance Mappzor
✔️ HL Verified
🚂 Steam Linked
💻 Oldtimer
Joined
Nov 21, 2003
Messages
17,065
Best answers
0
Maby you should edit that it dosent work with CZ aswell.
Cause now it only says Counter Strike.

PS Sticky candidate :p
 
Lost in space
Banned
💻 Oldtimer
Joined
Dec 21, 2003
Messages
3,608
Best answers
0
you forgot to mension the common problem that newbies have like "i can't install esf" (which is fixed by running hl once before installnig ethier 1.2.2 or 1.2.3 full installers/patches)

also with "your client dll differs" , 1.2.3 is no client dll change (just note you will need to install 1.2.2 before 1.2.3 to fix this) 1.2.3 is just map fixes for the gero skybox glitch and adds the new map esf_arrival. However this is only for the people that use the patches to update esf and no need to worry for people who have 1.2.3 full installer.
 
Lost in space
Banned
💻 Oldtimer
Joined
Sep 20, 2003
Messages
3,211
Best answers
0
Sorry I didn't update sooner. I was a tad busy.

Anywho. I edited Grega's and Saiyan Overlord's post, and added them to the list. Thanks guys. And proper credit is given as well. ^.^
 
brainfeeder
💻 Oldtimer
Joined
May 29, 2002
Messages
5,179
Best answers
0
Has my vote for a sticky, let's see if I can't get a fellow mod to do the deed.
 
New Member
💻 Oldtimer
Joined
Mar 6, 2003
Messages
3,999
Best answers
0
Stickied.

If a higher up disagrees, they can of course desticky.
 
Lost in space
Banned
💻 Oldtimer
Joined
Dec 21, 2003
Messages
3,608
Best answers
0
I got some credit :)

I should also mension the meleesounds.sc problems that some people get here and there. If you game starts up and the you get an error of "can't find meleesounds.sc" then ethier create a folder and name it meleesounds &/or then in the folder , save a blank notepad document and name it "meleesoundss.sc" , but the "s in as when you save it that will determine the file type. Also note that this method of fixing this problem is case sensitive.
 
Lost in space
Banned
💻 Oldtimer
Joined
Sep 20, 2003
Messages
3,211
Best answers
0
Saiyan_Overlord said:
I got some credit :)

I should also mension the meleesounds.sc problems that some people get here and there. If you game starts up and the you get an error of "can't find meleesounds.sc" then ethier create a folder and name it meleesounds &/or then in the folder , save a blank notepad document and name it "meleesoundss.sc" , but the "s in as when you save it that will determine the file type. Also note that this method of fixing this problem is case sensitive.
Updated. Thanks.

I also have a few questions myself. For the server crashes. Is there anything to add to what I posted?

Also to the Steam ticket expiring, is there anything I'm missing there as well?

If so please tell me so I or a mod can edit my original post. Thanks.
 
Lost in space
Banned
💻 Oldtimer
Joined
Dec 21, 2003
Messages
3,608
Best answers
0
I think that most situations that most users are at fault for that. It would ethier be th Computer they are using host the server (speculation of the problem could be your net connection &/or your system specs , software problems ,some custom user mods that may be in use may have bugs through them that could cause the game to crash etc). Try tweaking around with your server settings and such to see what is most stable to see if you cannot solve the problem.

EDIT: oh and firephoenix , you might want to add that bit in the first post of where iedited the post mensioning that melesounds.sc folder/file is case sensitive , sorry i must of just edited my post when you posted then. I also got the folder name wrong since i haven't answered trhis question in a long time , it's events folder not meleesounds folder (/me slaps self ><)

EDIT2 : also just another mension of the dragonball problems. Not all maps support dragonballs when you use CTDB(Capture the dragonballs) game mode , and the riverside map is the only default esf map at the moment that supports dragonballs , but there's an issue with it sometimes that causes one or sometimes more dragonball to not spawn at all. If you are looking for maps that support Dragonballs , then download some maps from esf-world
 
Lost in space
Banned
💻 Oldtimer
Joined
Dec 21, 2003
Messages
3,608
Best answers
0
Grega said:
meleesounds neaded

just unrar this :p http://www2.arnes.si/~gmegli1/events.rar

goes into your ESF foulder
or they can just create the events folder in their esf dir and create a blank meleesounds.sc text document witch they will have to save in "s as "meleesounds.sc" in notepad to the events folder

I also though it would be handy to mension problems people seem to have with the ingame mp3 player

1st things 1st , make sure your mp3 player is enabled , you can check this by going to options > Multiplayer > advanced and then ticking or unticking the Mp3 player box
If you are getting errors that won't start the playlist editor , then start steam and such and see if that works (worked for me at one stage). If that in any way does not help or the playlist editor still refuses to load , then there is an alternitive way of making your desired changes to the playlist. If you look in the mp3 folder you see that there is a txt file (playlist.txt) and a .def file (playlist.def). These should be opened with notepad , and from here you can add music aslong as you specifiy the location or the song (if you look at the related files you will get the picture)
 
Super Moderator
💻 Oldtimer
Joined
Dec 1, 2001
Messages
3,125
Best answers
0
I fixed the 'meeleesounds.sc' fix, so that it gives the proper directory now. I also fixed fixed the grammar and spelling. Ok so I basically re-wrote it.
 
New Member
Joined
Jul 29, 2005
Messages
1
Best answers
0
ok i dont get this, someone please help me just email me at ku4ba20@aol.com i wont be checking this THAT often...my problem is that i cant play esf at all some esf\cl_dlls\client.dll error it wont load it nothing works, i have steam, hl 1 legit copy, esf 1.2.3 full installer, and fmod.dll noting woks so now what..email me if u can help thnx
 
Lost in space
Banned
💻 Oldtimer
Joined
Sep 20, 2003
Messages
3,211
Best answers
0
Kuba said:
ok i dont get this, someone please help me just email me at ku4ba20@aol.com i wont be checking this THAT often...my problem is that i cant play esf at all some esf\cl_dlls\client.dll error it wont load it nothing works, i have steam, hl 1 legit copy, esf 1.2.3 full installer, and fmod.dll noting woks so now what..email me if u can help thnx
Does it say your client.dll differs from the server? If so, it means that you are trying to join a server that is of a different version of yours. You have 1.2.3 the server you were trying to join probably was either 1.2.2, 1.2.1, 1.2, or 1.1 something around there.

If this happens on all servers. Can't help you there bud, sorry, don't know the answer to that.
 
Lost in space
Banned
💻 Oldtimer
Joined
Dec 21, 2003
Messages
3,608
Best answers
0
Fire Phoenix said:
Does it say your client.dll differs from the server? If so, it means that you are trying to join a server that is of a different version of yours. You have 1.2.3 the server you were trying to join probably was either 1.2.2, 1.2.1, 1.2, or 1.1 something around there.

If this happens on all servers. Can't help you there bud, sorry, don't know the answer to that.
People with 1.2.2 can still join 1.2.3 servers and the other way around , Theres no client dll difference between 1.2.2 and 1.2.3 , 1.2.3 is map fixes for gero day/night skybox and adds the arrival map (The Maps may differ from the servers though depending on what version they are running , just keep that in mind).
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top