Server

New Member
Joined
Jul 8, 2006
Messages
48
Best answers
0
I'm having a problem with people joining my server. Very rarely does someone ever join. If I'm lucky, 1 person will join in like a 3 hour period. In my listen server, I had people joining every minute. What's wrong?
 
New Member
Joined
Apr 23, 2005
Messages
890
Best answers
0
Well if your connection speed isn't good or you have high latency/ping from other reasons, your servers latency is higher to other players. And people tend to choose server with lower latency coz otherwise it might lag a lot. I don't know what you mean with listen server?
 
New Member
💻 Oldtimer
Banned
Joined
Dec 1, 2002
Messages
2,725
Best answers
0
A little more information would be nice.

You're running a dedicated server on a different machine? I'd take it, then, that you're behind a NAT router? Ensure proper port forwarding in that case. HLDS listens, by default, on the single UDP port 27015.

Also, make sure you're not making a LAN-only server (using the command sv_lan 0 at server launch).
 
Active Member
💻 Oldtimer
Proud owner of HL
Joined
Nov 6, 2004
Messages
3,055
Best answers
0
DragonDude is half correct. You need to make sure you have the correct ports forwarded, however. The correct ports to forward are 27000 - 27030 UDP/TCP both enabled.
 
New Member
💻 Oldtimer
Banned
Joined
Dec 1, 2002
Messages
2,725
Best answers
0
Spunky said:
The correct ports to forward are 27000 - 27030 UDP/TCP both enabled.
No, they are not. I'm tired of you propagating this lie. I'm running a dedicated server at this very moment, with nothing forwarded to the machine but UDP port 27015.

What ports would I forward if, say for example, I run HLDS with +port 50000? Do I forward ports 49985-50015...?

By telling users to open these extra ports, you're doing nothing but confusing them and opening more of a security risk than what is required for running the server. You've been told this before, and I'm beginning to think you continue just to be stubborn. Stop it now.
 
Freelance Mappzor
💻 Oldtimer
Proud owner of HL
Discord Linked
Joined
Nov 21, 2003
Messages
17,065
Best answers
0
Forward the port 27015 on your router. And it should work better.

A side note. Did youinstall EVM?
 
New Member
Joined
Jul 8, 2006
Messages
48
Best answers
0
I use ESF 1.2.3, EVM Core, and a model pack. I'm using ESF 1.2.3 Dedicated Server with UDP Port: 27015

No one joins anymore. I used to get alot of people in my dedicated server when I first got it, but now I get nobody..not one, even in 3 hours. Btw, I put in sv_lan 0. Also, I get this error in my client console when I join:

WARNING: UDP_OpenSocket: port: 27015 bind: WSAEADDRINUSE
NET Ports: server 27015, client 27005
Could not get TCP/IP address, TCP/IP disabled
Reason: WSAENOTS
 
Active Member
💻 Oldtimer
Proud owner of HL
Joined
Nov 6, 2004
Messages
3,055
Best answers
0
Drew said:
Here, I'll give you all the info: All I have is ESF 1.2.3 installed, EVM Core only(just the sprites and stuff), and a model pack. I'm using ESF 1.2.3 dedicated server. UDP Port: 27015. No one joins anymore. I used to get alot of people in my dedicated server when I first got it, but I get none at all anymore..not even in 3 hours. I put in sv_lan 0 too, btw. Also I get this error in my console at server startup:

WARNING: UDP_OpenSocket: port: 27015 bind: WSAEADDRINUSE
NET Ports: server 27015, client 27005
Could not get TCP/IP address, TCP/IP disabled
Reason: WSAENOTS
That's because you need ports 27000-27030 TCP/UDP enabled!

@DD - I'll stick with my little "lie" until the day I die.
 
New Member
💻 Oldtimer
Joined
Mar 6, 2003
Messages
3,999
Best answers
0
Spunky said:
@DD - I'll stick with my little "lie" until the day I die.
No. You won't.

I'm hereby forbidding you from spreading around that information on this forum. It's causing a lot of confusion and believe it or not, you're wrong. If you object please feel free to take it up with another admin.
 
New Member
💻 Oldtimer
Joined
Sep 11, 2005
Messages
3,746
Best answers
0
Someone please tell me what ports to foward, The exact correct answer, please so I can host a server.
 
New Member
💻 Oldtimer
Joined
Aug 16, 2004
Messages
2,309
Best answers
0
The ports I use are:

27014 - 27016

And I've never had anyone complain about not being able to join my server.
 
Freelance Mappzor
💻 Oldtimer
Proud owner of HL
Discord Linked
Joined
Nov 21, 2003
Messages
17,065
Best answers
0
27015

Thats the one.



@Drew Ever think of the posibility that people in your area stoped playing ESF?

Cause most servers i see lately are totaly empty. People are on vacation. Heck half the servers i see in my list has 0 people in them.
 
New Member
💻 Oldtimer
Joined
Aug 16, 2004
Messages
2,309
Best answers
0
Grega, I'm not to sure of 27015 only

Cause sometimes I join a Counter-strike server and the port is 27014. /shrug

But! if ESF uses those ports only or something, then by all means I stand corrected. At least have 27015 open \o/
 
New Member
💻 Oldtimer
Joined
Sep 11, 2005
Messages
3,746
Best answers
0
Kaination said:
The ports I use are:

27014 - 27016

And I've never had anyone complain about not being able to join my server.

UDP or TCP?
 
New Member
💻 Oldtimer
Banned
Joined
Dec 1, 2002
Messages
2,725
Best answers
0
Spunky said:
That's because you need ports 27000-27030 TCP/UDP enabled!
And you're inferring that from... what? Even knowing nothing about Winsock, you could atleast search for the error on Google and see that you have no idea what you're talking about.

Drew - HLDS is trying to bind to port 27015, and can't. For some reason, something already has, so a new connection can't be established. Are you trying to run the dedicated server and client on the same computer? Something somewhere on your system has bound to port 27015, so HLDS can't. Either find out what's using the port, or run HLDS on a different port with the +port x flag.

Kaination - the port can be any one single port. I could tell HLDS, like I said in my last port, on port 50000 if I wanted to. The default port is 27015. It's not uncommon to see ports near 27015 (such as 27014 or 27016) being used, because the computer is running multiple HLDS processes (hence, multiple servers) and each HLDS needs a unique port to listen on.

And for clarification, all of these ports are UDP. Many games will use UDP for the actual game traffic because it requires no overhead, and is thus much faster and more suited for realtime applications.

The spread of misinformation in this section is absolutely frightening...
 
New Member
💻 Oldtimer
Joined
Aug 16, 2004
Messages
2,309
Best answers
0
Oh, I get it now. Thanks for clearing that up DD :)
 
New Member
Joined
Jul 8, 2006
Messages
48
Best answers
0
I start my dedicated server, and then I start my ESF and join my own server on the same comp. Then I open my console and find that error.
 
Freelance Mappzor
💻 Oldtimer
Proud owner of HL
Discord Linked
Joined
Nov 21, 2003
Messages
17,065
Best answers
0
Whats the server IP?

Ill check if my client can find it.

If it can than your server isnt the problem.

But if you see that error ingame in your console. That means that the client has it not the server.
 
New Member
💻 Oldtimer
Banned
Joined
Dec 1, 2002
Messages
2,725
Best answers
0
Drew said:
I start my dedicated server, and then I start my ESF and join my own server on the same comp. Then I open my console and find that error.
That's our problem. The client and the server both use port 27015, and two processes can't use the same port simultaneously.

If this is what you're going to be doing all the time (I wouldn't recommend it, but there's nothing inherently wrong with it), then run HLDS on a different port. Say, 27016. All you need to do is either change the port in the Windows HLDS GUI, or use the command-line switch -port 27016 upon launching HLDS. Then, just change the forwarding rule in your router so it forwards 27016 rather than 27015, and you should be golden.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top