Fixes for bugs in ESF+HL1 Beta (Inlcluding other HL1 mods and CS 1.6)

Swag
👮 Moderator
Joined
May 9, 2009
Messages
917
Best answers
1
There are a lot of issues to tackle at the moment as Valve is updating HL1. The main reason they decided to do so now is to make HL1 compatible with Linux. Which they're also celebrating with a sale atm; so you can get Half-Life 1 copies pretty cheap.

If you wish to see the changelogs, at least some of them (there are newer and ones not mentioned) Then check the spoiler out!
xPaw said:
This is not exactly FULL changelog, but should be enough.
Major change: GoldSource now runs on Linux/OSX, uses CEF to render MOTDs.
por
----
Update 1/29/2013

- Fixed game icon not showing in window title bar and/or dock
- Fixed OK button on Half-Life 1 deathmatch MOTD not being selectable if you ran in a non 4:3 resolution
- Added support for fast HTTP download when getting server assets for Linux and OSX
- Changed full screen render to fall back to changing the desktop resolution if it fails to create and offscreen FBO (useful on older video cards)
- Fixed crash if a game asked to play a sound with a volume that was too high
- Fixed rare crash on startup due to thread race conditions
----
Update 1/31/2013

- Fixed fans not rotating after being in a level for more than a few minutes
- Added "-nofbo" command line option to let you disable using the new method for rendering
- Added "-nomsaa" to let you disable MSAA effects being applied to the games output, setting "-nofbo" also implies "-nomsaa".
- Fixed not doing the HTTP fast download path if you canceled a download and then reconnected to the same server
- Fixed drowning damage being applied after respawn in some cases
- Fixed malicious clients being able to upload certain new files to servers
- Fixed some scripts sounds not playing
----
Update 1/31/2013

- Made save games cross platform
- Fixed crash when changing video modes under windows
- Removed support for A3D sounds from the engine, this API is not functional on current Windows OS releases
- Removed legacy D3D renderer, assorted OpenGL improvements in the beta make this older API not supportable
- Enabled hud_fastswitch on mouse wheel movement for Counter-Strike

----
Update 2/1/2013

- We have released an update for both games, fixes include:
- Added option to disable use of HD model packs in Video tab of options dialog
- Fixed mp_fadetoblack not applying after a flashbang is thrown (Counter-Strike)
- Fixed fullscreen software mode rendering incorrectly
- Added cl_min_t and cl_min_ct convar to let you control the model used when cl_minmodels is set, the value of the cvar is the model index to use (Counter-Strike)
----
Update 2/4/2013

- Fixed keyboard options dialog showing incorrect key names on non-QWERTY keyboards
- Fixed crash when typing in certain unicode characters
- Fixed voice chat sometimes not transmitting properly
- Allowed the toggleconsole command to be properly rebound
----
Update 2/5/2013
- Fixed alt-tab not working correctly, the game window is no longer forced on top
- Added "cl_mousegrab" cvar, if set to 0 then the game will not grab the mouse. This may be needed to enable alt-tab with some Linux window managers. You can also add "-nomousegrab" to your command line to disable mouse grabbing.
- Fixed error on launch loading mss32.dll under Windows
- Fixed hang on startup causing a black screen to display on OS X and Linux
- Update Server Browser display to match behavior of Source engine products
----
Update 2/6/2013

- Fixed crash when spectating players
- Fixed config files being written to the wrong folder, they are now always saved to the directory of the mod you are running. For Half-Life 1 this is "valve" and for Counter-Strike 1.6 this is "cstrike". You may lose some settings from this transition if you changed your configuration in the last couple of days
- Don't unpause the game when dismissing the Steam overlay if the game was already paused
- Allow mouse sensitivity to go down to 0.2 (from the previous floor of 1.0)
- Fix say and say_team commands using wrong characters on non-US keyboard layouts

----
Update 2/7/2013

- fixed hltv failing to launch
I figured if one update in a day is good, 2 are better! I've updated CS 1.6 again, this update fixes several server crashes due to bogus player pointers around connect/disconnect.

- Alfred



----
Update 2/8/2013

- Fixed viewdemo command crashing when run
- Fixed screenshot command crashing
- Fixed HD model packs not loading if available and enabled
- Fixed crash on launch if your graphics cards didn't support FBO's
- Fixed crash on launch under SELinux
- Fixed assorted crashes in Counter-Strike 1.6 due to bad string checks
----
Update 2/8/2013

- Fixed auto-complete list in game console jumping 2 entries at a time
- Fixed keypad enter not being a key you could bind in the Options dialog
- Fixed mouse wheel up/down not showing in the binding Options dialog
- Fixed Low Violence mode being applied incorrectly
- Made Condition Zero models being used in Counter-Strike 1.6 (if you own Condition Zero) optional and controlled by the HD Models check box in the Options Video tab.

- fixed hltv being unable to record demos under Linux
- fixed dedicated servers listing as a listen server
- (partially) fixed hltv listing on the master servers (you need a client update plus we need to do a server update to totally fix this)
----
Update 2/9/2013

- Fixed a crash if you had invalid data for a key bind in your config.cfg
- Fixed a crash for older opengl drivers (ones without FBO support)
- Don't quit the game if a server attempt to make you load an invalid model, just disconnect from the server
- Fixed crash on changelevel if save data was not available
- Fixed keypad period key not binding properly
- Fixed crash if you tried to manually force on D3D rendering mode (which is no longer available).
- Fixed hang on server connect if you fail to download some assets via HTTP

----
Update 2/11/2013

- Added ability to override default content. Enable the "Allow custom addon content" option in the Video options dialog and then place that content in valve_addon (or cstrike_addon for CS 1.6 ). This overridden data has all the normal VAC and pure server rules as default content
- Content downloaded from servers now goes into a separate valve_downloads (or cstrike_downloads ) folder, so you can easily clean up unwanted files
- Updated Video options tab to better expose new configuration settings and remove unused ones
- Increased maximum allowed rate setting to 100,000
- Fixed in game chat not using correct characters when using non-US layout keyboards
- Fixed bot column in server browser to show the number of bot players (and not a random image)
- Fixed player column sorted in server browser
- Don't lock the game to the first CPU on your machine under Windows
- Fixed loading config.cfg from the wrong path
- Fixed crash on joining server
- Fixed chat text showing previous line of text sometime in Counter-Strike 1.6
- Fixed fps_max to actually run at that framerate, not 1 less
- Fixed timing function used on Linux to better match system time, reducing frame time variability
- Fixed duck key not dismissing spectator UI in Counter-Strike 1.6

- fixed hltv demos being corrupted
- fixed downloading of custom sprays from users
- increased max rate to 100k (sv_min/maxrate still apply and defaults for them are unchanged)
- changed timing function to call clock_gettime(), this should cause more stable frame rates
----
Update 2/12/2013

- Enabled fully localized chat in Counter-Strike 1.6
- Made keypad enter key submit a command in the game console
- Fixed extra keys causing the console to toggle when using a non-QWERTY keyboard
- Fixed maps list in New Games option not showing all available maps
- Removed cl_rate command, "rate" is the appropriate command to use
- Fixed crash when using alt-tab in software mode
- Fixed crash if you set a bind to an invalid engine key
----
Update 2/13/2013

- Don't create the SAVE/ folder on disk unless needed by a game
- Fixed extra temporary files from the save process not being cleared up
- Fixed empty chat messages being allowed
- Fixed using backspace when using say or say_team command with non latin characters
- Fixed mouse offset when running in fullscreen software mode
- Fixed copying text from the game console not getting the last couple of character when doing multi

One more beta update before this becomes the public version tomorrow, changes are:

- enabled utf8 chat for say and say_team commands
- don't create a SAVE/ folder on server launch


The update has brought a lot of errors and bugs, some are not fixable but most of the heavy ones are.

First of all, if you are experiencing problems I suggest a clean re-install.

To do a complete clean re-install you'll have to go through some steps. Find them in the spoiler below:

First of all, delete both your folders the new and the old one. Currently they might collide with each other which won't lower the amount of bugs let's just keep it like that.

1. Delete the esf folder located here C:\Program Files (x86)\Steam\steamapps\<youraccname>\half-life
(Warning: Remember you might have a lot of old demos/maps you wanna save, and last but not least your config.cfg (all your binds and settings)

2. Delete the Half-Life folder located here C:\Program Files (x86)\Steam\steamapps\common

3. Find all your HL1 games which aren't mods (so not ESF)

4. Once you have found all right click on one by one, go to properties, select the beta tab and make sure they are opted into "beta-beta"

5. Once everything is opted into "beta-beta" start installing it all.

6. When you're done you should successfully be opted into the beta without any collision bugs.

7. You should now see new options, especially options like wait for vsync and such in the game's video settings.


Now even with a clean wipe and re-install bugs do often occur. I'll title every problem and then put plausible solution(s) inside a spoiler right below it.

Can't open your console? (If you can't then start with this step as some problems can only be fixed with a console)
Due to valve now deciding to make in-game support for non-Latin languages the game now allows you to use your default language on your keyboard so you type in-game the same way you do on Steam or on a word document.

This may have changed your console button, but no worries if you can't find the new button.

Method 1 to get your console back:
Go to Steam, then --> Library --> Right click on your game --> Go to the general tab --> Launch options --> and type -console in there. The game should start up with a console.
Then in the console type bind "the key you want" toggleconsole and this should now be your new key.

Note: If your config.cfg located in C:\Program Files (x86)\Steam\steamapps\common\Half-Life\esf (Or whatever game you're playing, instead of ESF) is set to read only, then this button won't be saved when you exit. Right click on it in your folder, go to properties and check if it's set to read only or not, if you want it on read only or have it on read only then untick it and do method 1 once more.

Method 2 to get your console back:
(x86)\Steam\steamapps\common\Half-Life\esf (Or whatever game you're playing, instead of ESF)
Locate your config.cfg file, right click on it and make sure you haven't set read only on. After that find bind "key" toggleconsole which should be somewhere on the file, and alphabetically set up.
Change the current key to whatever new key you want to, leave quotation marks and so alone.

Too high fps?
For some this isn't fixable, for others it is. I have seen 2 people who absolutely couldn't fix this, but the other 30 or so could so hopefully we can get it right!

First of all make sure all your HL1 games are set to opt to beta.

Quoted myself from above.
3. Find all your HL1 games which aren't mods (so not ESF)

4. Once you have found all right click on one by one, go to properties, select the beta tab and make sure they are opted into "beta-beta"

5. Once everything is opted into "beta-beta"
Second thing you wanna do is make sure your settings are set to not override fps further than 100. Type these commands into your console (Console won't open? Look above for a fix)

gl_vsync "0"
fps_override "0" (For some this command doesn't exist, yet)
fps_max 101
Also to make sure gl_vsync 0 goes into effect, go to your settings in-game and select video options and untick "wait for vsync"

If none of this fixes your fps then exit your game, go to your library, right click the game --> general tab --> launch options and type -nofbo inside your launch options and restart your game.

If this also doesn't fix it you're one of the few who can't limit their FPS, although in the new upcoming patch FPS shouldn't affect movement + the high fps problem will probably have an easier solution anyway.

Fps is limited at 60, I have disabled vsync through my graphic card control panel?
This is done from in-game now. To disable vsync you can check your video settings in-game and untick "wait for vsync"

Type in your console gl_vsync 0 as well, remember to have your config.cfg on not read-only (it is by default, so no worries if you haven't touched it before) If you can't find your console look above to fix it.

If none of this fixes your fps then exit your game, go to your library, right click the game --> general tab --> launch options and type -nofbo inside your launch options and restart your game.

My mouse is acting weird!

There are currently 3 issues regarding this, in ESF that is.

First issue is something a lot of people are experiencing with the mouse generally just acting weird.

Try to press esc twice, and see if it doesn't fix it.

If that doesn't work then you're having the second bug.

To fix that (I haven't confirmed if this works in ESF yet, works on CS!)
Go to your Steam --> Library --> Right click on ESF --> General tab --> Launch options and put this in: -noforcemspd -noforcemaccel -noforcemparms -nojoy


If it doesn't fix the problem then change it to -noforcemspd -noforcemaccel -noforcemparms -nojoy -nofbo

If this also doesn't work then there's maybe a third bug or so, or it's your own mouse/hardware.
There's a third problem where your mouse doesn't let you center while in menus, type m_rawinput 1 in your console and that should do the trick, if you cannot open your console read above.

Weird turns, left is up and such
Edit: It seems like the m_rawinput is what gives the weird turns with the mouse, turning m_rawinput back to 0 and then 1 again fixes this (temporarily)


My FPS is way too low/My game crashes/My textures are weird/My screen colour is weird/When I move or turn my screen goes weird
All those problems are due to the new way of rendering, which doesn't seem to work on all (older) pcs.

Go to your library, right click the game --> general tab --> launch options and type -nofbo inside your launch options and restart your game.

Yes, that simple command was added to fix a bunch of issues. And came with the updates. Hopefully it fixes your issue(s).

Another thing you can do is untick HD models and tick the "for slow graphic card option".

cl_EntityNum: 465 is an invalid number, cl.max edicts is 465 or similar numbers in an error
There are 2 fixes for this, let's start with the permanent one. (I myself had that error and it fixed it for a couple of others too!)

Go to your Steam --> Library --> Right click on your game --> Properties --> General tab --> Launch options and type in -num_edicts 3072.

The temporary fix shouldn't really be done as it'll annoy you by the end of the day. Go create a game server on LAN and then you can join other servers and may later on get the error again and will get it again when you restart.

Where are my/the servers?
The servers that are not on the list haven't yet been updated, therefore you'll have to use other methods.

One is using pages to track servers running in the game:

Once you find or hear about them add them to your favourites, they should appear there.

One you know an IP connecting to a server is simple.
Type in your console

connect [noparse]ip:port [/noparse]
Example: connect 188.40.15.249:27016

If it's your own server and you want it back on the list:
if you guys want your servers to show up on the server list again you have to properly use steamcmd now.
m_rawinput issues have been fixed if you set your Half-Life to receive the beta updates.
More questions/fixes/suggestions/issues to add? Go ahead!
 
Last edited by a moderator:
Judge. Jury. Executioner
👮 Moderator
★ Black Lounger ★
💻 Oldtimer
Joined
Aug 26, 2010
Messages
2,241
Best answers
1
Nice thread, am sure it'll help a lot of people. It might be the wrong sub-forum but am gonna ask for a Sticky.
 
Last edited:
Judge. Jury. Executioner
👮 Moderator
★ Black Lounger ★
💻 Oldtimer
Joined
Aug 26, 2010
Messages
2,241
Best answers
1
My bad, I meant sub-forum. This would be better in Help and Support, no?
 
New Member
💻 Oldtimer
Joined
Jun 18, 2003
Messages
5,935
Best answers
0
Ah, maybe. I feel like everyone who wants to play ESF is going to run into these problems, and more people visit ESF Chat. I wish there was a way to have the same thread stickied in both forums.
 
Proud owner of Half-Life
Joined
Mar 20, 2004
Messages
37
Best answers
0
Issues with no fixes....

-There is a teleport lag after you recharge // you can check this one out when you create your own game.... and watch how fast u can teleport
- beams lagg your fps... you have to rejoin server to fix fps
- fps in servers just drop sometimes.
 
Last edited:
Swag
👮 Moderator
Joined
May 9, 2009
Messages
917
Best answers
1
Beams always lagged your fps at the end, for some reason it remembers all the things you did until you reconnect.

But try the -nofbo command.

Go to your library, right click the game --> general tab --> launch options and type -nofbo inside your launch options and restart your game. I don't know if it'll be fixed but if it worked on the old engine it might work. What it does is make it render the game on the old engine.
 
Proud owner of Half-Life
Joined
Mar 20, 2004
Messages
37
Best answers
0
i hate this new update, feels like i just got abused by some homo and it killed the whole game.
 
Steam Registered User
Joined
Dec 12, 2011
Messages
409
Best answers
0
well I think there was another update or something; servers are working fine for me now.
 
Proud owner of Half-Life
Joined
Oct 2, 2009
Messages
75
Best answers
0
What should I choose to have a higher FPS? My screen resoliution: 1366x768
 
New Member
💻 Oldtimer
Joined
Jun 18, 2003
Messages
5,935
Best answers
0
There are probably some console commands you can use, but I think lowering your resolution will increase your fps. Maybe try checking the box that says low video quality, but who knows if it'll do anything with ESF.
 
New Member
💻 Oldtimer
Joined
Aug 2, 2002
Messages
1,227
Best answers
0
Wait for vertical sync will mean your client will run at 60FPS max if you have a tft monitor. iirc
 
Proud owner of Half-Life
Joined
Mar 20, 2004
Messages
37
Best answers
0
alright reinstalling everything fixed most of my problems
 
Swag
👮 Moderator
Joined
May 9, 2009
Messages
917
Best answers
1
[-1-];1962415 said:
alright reinstalling everything fixed most of my problems
Which is the first thing my thread suggests :p
 
Swag
👮 Moderator
Joined
May 9, 2009
Messages
917
Best answers
1
Added another fix:

There's a third problem where your mouse doesn't let you center while in menus, type m_rawinput 1 in your console and that should do the trick, if you cannot open your console read above. (Got it from Grega ;) ) Thanks Grega!

Also, there seems to be one where you turn weird, trying to find a solution for that.

Edit: It seems like the m_rawinput is what gives the weird turns with the mouse, turning m_rawinput back to 0 and then 1 again fixes this (temporarily)
 
Last edited:
New Member
💻 Oldtimer
Joined
Aug 2, 2002
Messages
1,227
Best answers
0
Not that i know of, but SCCM's 2012 SP1 solved quite a few problems i had with the RC
 

Users Who Are Viewing This Thread (Users: 0, Guests: 2)

Top