Refuses to change gametype?

New Member
Joined
May 23, 2005
Messages
11
Best answers
0
Hello.

When I started my server, via. clicking the 'Create Server Button' in ESF, there was an option called 'Gametype.' It was set on 'Teamplay'. However, I did not want to played Teamplay, but instead wanted to collect dragonballs, therefore setting it to CTDB. Yet when I started the server, it was still set on teamplay. I tried 3 times with the same result. This also occured when I attempted to put 'Freefight'.

Does anyone know how to fix this?

Thanks,
Crazy "ESF Noob" Demon
 
Senior Member
★ Black Lounger ★
✔️ HL Verified
💻 Oldtimer
Joined
Feb 17, 2003
Messages
1,483
Best answers
0
The default esf maps for the most current release arent made with dragonball spawn points. Find a nondedfault map with dragon ball spawn points. Dont use riverside. Often a dragonball spawns underground and you can not grab it.
 
New Member
Joined
May 23, 2005
Messages
11
Best answers
0
Hello.

I believe you have misunderstood me. What I mean is that, for example I set the gamemode to Free Fight. I start the server and is it Free Fight? No sir, it is teamplay. Everytime I start a server, no matter what gamemode I change to, it stays on teamplay.
1)I ask again, how do I change the gameplay so that it is NOT teamplay?
2)To Ravendust: The file you gave me is a .rar file. Inside the 'Maps' Folder, the maps are .bsp files. Are you sure that is the right file?
3)If it is, what folder do I put it in?

Thanks,
Crazy "ESF Noob" Demon
 
New Member
Joined
May 31, 2004
Messages
30
Best answers
0
Check the listenserver.cfg to see what gametype is specified (it's a number, and correspondends to the order in the game)

I forgot the correct referring:
But I thought 1 = Free For All
2 = Team
3 = Capture The DragonBall
IF I'm wrong it's
0 = Free For All
1 = Team
2 = Capture The Dragonball
(And I think it's the bottom one :p)

listenserver.cfg is in the esf folder
look for g_gametype or something like that.

Just change it into the gametype you want it to be and it should work.
 
New Member
Joined
May 23, 2005
Messages
11
Best answers
0
Hello.

Taking your advice Omega, I found that there was no g_gametype in the 'listenserver.cfg' file. However, I found a similiar name in the 'game.cfg' file.

// Half-Life Server Configuration Settings
// DO NOT EDIT, GENERATED BY HALF-LIFE

// File generated: Tue Mar 09 03:53:10 PM
//
//
// Cvar - Setting

"mp_fraglimit" "0.000000"
"mp_timelimit" "0.000000"
"mp_wishlimit" "0.000000"
"mp_falldamage" "0"
"mp_gamemode" "1"
"mp_realteams" "0"
"mp_friendlyfire" "0"
"mp_allowspectator" "1"
"mp_plcatchup" "1"
"mp_multipleps" "1"
"mp_forcerespawn" "0"
"mp_footsteps" "1"
"mp_lockmodels" "1"
"mp_spawn_invulnerable_time" "4.000000"
"mp_characterlimit" "0.000000"
"sv_sendvelocity" "1"
"numbots" "0.000000"
"bot_skill" "1"

Is mp_gamemode what you were talking about?
 
New Member
💻 Oldtimer
Joined
Jun 8, 2004
Messages
5,216
Best answers
0
2)To Ravendust: The file you gave me is a .rar file. Inside the 'Maps' Folder, the maps are .bsp files. Are you sure that is the right file?
You have to open it up with WinRAR and then put the .bsps in the Maps folder. Rawr!
 
New Member
Joined
Mar 6, 2005
Messages
29
Best answers
0
Let me help out since I've had this problem before. Go to your ESF folder. Then find the file that says game.cfg and open it with notepad. There you will see something like so:

// Half-Life Server Configuration Settings
// DO NOT EDIT, GENERATED BY HALF-LIFE
// File generated: Tue Mar 09 03:53:10 PM
//
//
// Cvar - Setting

"mp_fraglimit" "0.000000"
"mp_timelimit" "0.000000"
"mp_wishlimit" "0.000000"
"mp_falldamage" "0"
"mp_gamemode" "2"
"mp_realteams" "0"
"mp_friendlyfire" "0"
"mp_allowspectator" "1"
"mp_plcatchup" "0"
"mp_multipleps" "1"
"mp_forcerespawn" "1"
"mp_footsteps" "1"
"mp_lockmodels" "1"
"mp_spawn_invulnerable_time" "1.000000"
"mp_characterlimit" "0.000000"
"sv_sendvelocity" "1"
"numbots" "0.000000"
"bot_skill" "1"

I use this configuration for my EVM server. (Yes, "mp_gamemode" "2" is CTDB mode.)
 
Senior Member
★ Black Lounger ★
✔️ HL Verified
💻 Oldtimer
Joined
Feb 17, 2003
Messages
1,483
Best answers
0
just delete the game.cfg

it shouldnt exsit there in the first place and half-life will read from that after it reads from the server.cfg or listenserver.cfg
 
New Member
💻 Oldtimer
Joined
Sep 8, 2002
Messages
2,278
Best answers
0
Okay, here's whatcha do.

Go and find game.cfg (The cause of most people's trouble) and open it w/ notepad. Find the gamemode cvar and edit it to your liking then save.

The problem with game.cfg is that it overwrites your server.cfg setting the first time you start your server, so no changes are made until map change or "restart" in console.

So, I suggest either DELETING it OR copying the contents of your server.cfg into it then saving.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top