FullNovaAlchemist's best answers

  1. FullNovaAlchemist

    I can't seem to play the game online

    not really you only need esf 1.2.3 but servers are dead because next to no one plays anymore
Top