Server don't start...

New Member
Joined
Mar 12, 2009
Messages
3
Best answers
0
Hi there i have a Linux Root Server and installed the esf 1.2.3 on a half life 1 dedicated server... When i start the server I get follow problem:

LoadLibrary failed on ./esf/linuxdlls/hl_i386.so: ./esf/linuxdlls/hl_i386.so: undefined symbol: sqrt
Host_Error: Couldn't get DLL API from ./esf/linuxdlls/hl_i386.so!
FATAL ERROR (shutting down): Host_Error: Couldn't get DLL API from ./esf/linuxdlls/hl_i386.so!

Have anyone an idea what it is?
The File is in the folder...
 
New Member
✔️ HL Verified
Joined
Mar 13, 2009
Messages
155
Best answers
0
I didn't even thought that someone plays ESF on Linux... :p
 
Freelance Mappzor
✔️ HL Verified
🚂 Steam Linked
💻 Oldtimer
Joined
Nov 21, 2003
Messages
17,065
Best answers
0
I didn't even thought that someone plays ESF on Linux... :p
It doesnt. STEAM doesnt let it. But you can still make dedicated servers using Linux.
 
Freelance Mappzor
✔️ HL Verified
🚂 Steam Linked
💻 Oldtimer
Joined
Nov 21, 2003
Messages
17,065
Best answers
0
so it is impossible to make an esf server on linux?
Its possible to make a dedicated server. Its not possible to play the game on linux though.
 
New Member
Joined
Mar 12, 2009
Messages
3
Best answers
0
i want to host the dedicated esf server and u telling me something about playing the game on linux...
 
Freelance Mappzor
✔️ HL Verified
🚂 Steam Linked
💻 Oldtimer
Joined
Nov 21, 2003
Messages
17,065
Best answers
0
Actually i anwsered error since i quoted his post. Im no linux man so i dont know about your error.

All i can suggest is that you doublecheck if you downloaded the linux server version of the game.

BTW there was a bug after a STEAM update. You can fix it with making a txt file with some numbers in it. but i dont know the name of the file or what numbers to put in.
 
New Member
Joined
Apr 1, 2009
Messages
4
Best answers
0
Hi there i have a Linux Root Server and installed the esf 1.2.3 on a half life 1 dedicated server... When i start the server I get follow problem:

LoadLibrary failed on ./esf/linuxdlls/hl_i386.so: ./esf/linuxdlls/hl_i386.so: undefined symbol: sqrt
Host_Error: Couldn't get DLL API from ./esf/linuxdlls/hl_i386.so!
FATAL ERROR (shutting down): Host_Error: Couldn't get DLL API from ./esf/linuxdlls/hl_i386.so!

Have anyone an idea what it is?
The File is in the folder...
I am having the exact same problem, I am running a Dedicated Linux HL server. Downloaded the ESF Linux install via hl2files.com.

Does anyone have a solution for this problem? Other server Guru's perhaps?
 
New Member
Joined
Apr 1, 2009
Messages
4
Best answers
0
I had the same problem with a TS server.

The file has to be steam_appid.txt and the only thing in it should be the number 70.

That's the thing Grega is talking about.

About the so-file, i still have the same error. It's something to do with hlds having a few problems with some mods. Don't know more yet. If I find an answer i'll let ya all know.
 
New Member
Joined
Apr 1, 2009
Messages
4
Best answers
0
I'd like to bump this problem as I'm still unable to run a linux HLDS server with ESF installed.

Again, problem occurs during server startup:

LoadLibrary failed on ./esf/linuxdlls/hl_i386.so: ./esf/linuxdlls/hl_i386.so: undefined symbol: sqrt
Host_Error: Couldn't get DLL API from ./esf/linuxdlls/hl_i386.so!
FATAL ERROR (shutting down): Host_Error: Couldn't get DLL API from ./esf/linuxdlls/hl_i386.so!
 
Oldtimer
✔️ HL Verified
🚂 Steam Linked
Discord Member
Joined
Jan 27, 2003
Messages
297
Best answers
0
Ah yessir that'll be the one. Untarred\UnGzipped it, uploaded it. Made the servername change aswel as a few choice MP_ values and then loaded it up. Its a no go :(

I can send you the entire log if you like.


EDIT: ah yes i got my main account back so dont be getting confused :) Myst = me.
 
Last edited:
NOT IN THE MANGA™
★ Black Lounger ★
✔️ HL Verified
🚂 Steam Linked
💻 Oldtimer
Joined
Jan 5, 2008
Messages
3,276
Best answers
0
Hi. Today I've installed ESF Dedicated Server for Linux (used files from here).

At first I got problem the same as Mystacx. Then I installed Metamod-P and got this:
Code:
==================
Game DLL version mismatch
DLL version is 140, engine version is 140
The game DLL for esf appears to be outdated, check for updates
==================
Host_Error:

FATAL ERROR (shutting down): Host_Error:
I've successfully started HLDM server right before trying to start ESF one.
Tried to change ESF's hl_368.so to HL's hl_368.so - no use.

Team members should support this, shouldn't they? Or ESF 1.2.3 is no longer supported?
 

Users who are viewing this thread

Top