Need older ATI Drivers...

New Member
✔️ HL Verified
💻 Oldtimer
Joined
Jun 17, 2003
Messages
3,397
Best answers
0
I swear the new ATI Catalysts drivers are freaking ****, my bro can't even run source games anymore without it having a blue screen of death. I've reinstalled DirectX, Catalyst, etc.

So, does anyone know where I can find old ATI Catalyst drivers? I can't find a clean copy without something hidden in it.
 
Active Member
✔️ HL Verified
💻 Oldtimer
Joined
Nov 6, 2004
Messages
3,055
Best answers
0
No idea dude, you sure ATI doesn't offer legacy drivers on their site?

What card are you using?
 
New Member
✔️ HL Verified
💻 Oldtimer
Joined
Jun 17, 2003
Messages
3,397
Best answers
0
Maybe I should have been more patient D:, thanks Spunkeh
 
Active Member
✔️ HL Verified
💻 Oldtimer
Joined
Nov 6, 2004
Messages
3,055
Best answers
0
No problem. :D
 
New Member
✔️ HL Verified
💻 Oldtimer
Joined
Jun 17, 2003
Messages
3,397
Best answers
0
I never heard of Omega but I'm currently reinstalling HL2 DM to see if it creates that blue screen again.
 
New Member
Joined
Oct 8, 2002
Messages
136
Best answers
0
Lith what drivers are you currently now using?
Im about to roll back to the original drivers on the ati discs that come with the gfx card and they are quite old because i have some weird mouse error in cs 1.6/cz
 
New Member
✔️ HL Verified
💻 Oldtimer
Joined
Jun 17, 2003
Messages
3,397
Best answers
0
Lith what drivers are you currently now using?
Im about to roll back to the original drivers on the ati discs that come with the gfx card and they are quite old because i have some weird mouse error in cs 1.6/cz
Yeah my brother had that mouse problem but in any other game it works fine. Try setting the rendering to OpenGL.
 
New Member
Joined
Oct 8, 2002
Messages
136
Best answers
0
Yeah thats the exact same problem here
Yea i only use OpenGl and never ever d3d in any game, i just rolled back to the original drivers on disc and the mouse problem seems to be gone i think but its really laggy ingame and fps seems to be quite low, do you have any other solutions??? what drivers is your brother using now or how did he fix the problem
Thanks for your help
 
Active Member
✔️ HL Verified
💻 Oldtimer
Joined
Nov 6, 2004
Messages
3,055
Best answers
0
If you know the drivers you're using, slowly move up to the most recent you possibly can. That's what I would do. Or go every other driver if you're not very patient.
 
New Member
✔️ HL Verified
💻 Oldtimer
Joined
Jun 17, 2003
Messages
3,397
Best answers
0
Alright I just tried the Omega Drivers and...






HOLY CRAP it's fast as hell! No lag spikes, etc. Doku man, thanks!
 
Now with Kung-Fu action!
✔️ HL Verified
💻 Oldtimer
Joined
May 13, 2004
Messages
1,761
Best answers
0
Alright I just tried the Omega Drivers and...






HOLY CRAP it's fast as hell! No lag spikes, etc. Doku man, thanks!
My name practically means doctor-help. I'm glad you're playing smooth. Now if Omega finally released his Vista Drivers :devgrin:.
 
New Member
Joined
Oct 8, 2002
Messages
136
Best answers
0
I just installed the latest omega drivers and now i cant play cs 1.6 in OpenGl or d3d, it says "The specified video mode is not supported. The game will now run in software mode" wtf? any ideas?
 
Active Member
💻 Oldtimer
Joined
Jun 6, 2004
Messages
2,275
Best answers
0
Yeah omega drivers rock so hard.

After installing them I've never gone back.
 

Users who are viewing this thread

Top