Metamod All-Mod support

Senior Member
★ Black Lounger ★
💻 Oldtimer
Joined
Feb 17, 2003
Messages
1,483
Best answers
0
Woohoo, hullu is back :p

All-mod metamod information. The ents (DONT COMMENT ABOUT THAT) are not hardcoded, but instead they are dynamic. In otherwords, no need to update metamod ANY MORE with this. (unless steam presents a problem)

Heres the link:
http://metamod-p.sourceforge.net/

*edit: Due to update of this metamod*
*edit: Home website of this changed*
------Also got rid of my anti UA chat. (I was mad at UA at the time I origionally made this)
 
New Member
💻 Oldtimer
Joined
Sep 8, 2002
Messages
2,278
Best answers
0
Last time I tried using this kind of metamod (with the whole "dynamic instead of hardcoded" thing) it failed miserably! I used it on ESF v1.0.
 
New Member
💻 Oldtimer
Joined
Sep 8, 2002
Messages
2,278
Best answers
0
I used WON when v1.0 was out, and that dynamic MM dll was for WON.

Well, anyways, I'll give this a shot but I have very little confidence in it given my past experiences.
 
Senior Member
★ Black Lounger ★
💻 Oldtimer
Joined
Feb 17, 2003
Messages
1,483
Best answers
0
Nor do I, but I need to give options to the players of this game.
Read my post again.
I said several times that I was pissed about releaseing this.
 
New Member
💻 Oldtimer
Joined
Nov 4, 2002
Messages
1,061
Best answers
0
Stickied. Seems like everyone in the halflife community is getting lazy with things right when esf picks up...
 
Senior Member
★ Black Lounger ★
💻 Oldtimer
Joined
Feb 17, 2003
Messages
1,483
Best answers
0
This metamod has been updated:
June 7, 2004
 
New Member
Joined
Jan 2, 2005
Messages
46
Best answers
0
Does anyone have the IP of a Steam Server
 
Super Moderator
💻 Oldtimer
Joined
Dec 1, 2001
Messages
3,125
Best answers
0
Munch said:
Does anyone have the IP of a Steam Server
You already posted in a thread that you can't find servers saying you can't find 1.2.1 servers. That's because ESF is now at version 1.2.3b, update, and you will find servers. Please don't spam threads in the future,
 
New Member
Joined
Apr 6, 2005
Messages
4
Best answers
0
ehem.

KilledWithStyle:
Only thing I have to do with United Admins is that they host my forums. You could have just post real webpage of Metamod-P (http://koti.mbnet.fi/axh/) instead of forums. United Admins doesn't code or support Metamod-P and has nothing to do with it.. it's my project.

Mr. Satan:
There have been different Metamod projects that tried to do same as MM-P by different methods. If MM-P doesn't work for you, please, post details to me.. link to support forums are at my homepage: http://koti.mbnet.fi/axh/

PS. I'm Hullu.
PSS. If you have webspace to me to host forums, send me PM.
 
Senior Member
★ Black Lounger ★
💻 Oldtimer
Joined
Feb 17, 2003
Messages
1,483
Best answers
0
Ok then I will post to your website and yes I do have plenty of space for forums. If you dont mind something like www.apecenter.com/planZeta/ (whatever you want to name it)
And if you have your own registered name, I can always just add the name to the account to refer you to a website on there.

Welcome to ESF hullu, did you trace URL refers back to this site or something?
 
New Member
Joined
Apr 6, 2005
Messages
4
Best answers
0
I have registered Metamod-P at sourceforge now and will be moving there soon.

Someone had problems with ESF&MM-P and after fixing I decided to check these forums for any MM-P talk.
 
Senior Member
★ Black Lounger ★
💻 Oldtimer
Joined
Feb 17, 2003
Messages
1,483
Best answers
0
Well its there if you want it.

Really.... I seem to have had no problem. Maby its because I use a slightly outdated version. And I remember one of the newer versions had some trouble with Amx mod X, maby that is thier problem.
Let me seee.... I use:
1.17.3p14
 
Senior Member
★ Black Lounger ★
💻 Oldtimer
Joined
Feb 17, 2003
Messages
1,483
Best answers
0
I stoped downloading new versions cause you kept updating it so much that I eventually got tired of updating every version. So eventually I just got to the point to where every time it hits me on the head to update I would (which is rare)


anyhoo this still doesn't cover the core subject:
What kind of problems were ESF ppl having?

Cause some of thiese people were asking me, and they know little to nothing about what metamod/AMX mod X is. And I was wondering if it was a ESF specific problem or a user problem. Cause most of thiese people, at least I believe, should really get used to basic servering before they install all of the server addons. But ESF seems to be filled with .... young.... people and they want to seem good and grab as much server stuff as they can without knowing what to do with it.

For those who are having troubles, follow my easy step guide.
1. Download the most recient version of Metamod-P
2. Extract Metamod-p to /path/to/esf/addons/metamod/dlls/
3. Go to the ESF directory and open up liblist.gam (with notepad)
4. Go to the gamedll and gamedll_linux lines and
If you are on windows replace gamedll with:
gamedll "addons/metamod/dlls/metamod.dll"
If you are on linux replace gamedll_linux with:
gamedll_linux "addons/metamod/dlls/metamod.so"
5. Go to the metamod directory and create/edit a plugins.ini and a config.ini
Note: Ignore the plugins.ini and config.ini in the doc folder.
6. Open up config.ini and replace it with this:
gamedll dlls/hl.dll
autodetect yes
(dont ask me why I put both. I just remember that I had a problem once that was only solved by putting both like this)

Your virtually done, but listen some more on how to install modules:
7. Go to that plugins.ini and edit it.
If you are on windows:
win32 path/to/whatever/you/choose.dll
If you are on linux:
linux path/to/whatever/you/are/doing/that/is/linux.so

And you should be done. And please note: path/to/whatever(etc etc etc) starts in your ESF directory and goes up. So if you are doing entmod: (the entmod file in this hypothetical situation is in c:\path\to\esf\addons\EntMod\dlls\)
win32 addons/EntMod/dlls/EntMod_MM.dll
linux addons/EntMod/dlls/EntMod_MM.so
 
New Member
Joined
Apr 6, 2005
Messages
4
Best answers
0
KilledWithStyle said:
anyhoo this still doesn't cover the core subject:
What kind of problems were ESF ppl having?
Linux version causes problems because mod-dll is in 'linuxdlls' path instead of standard 'dlls'. Developers should fix this and go with the standards.

*edit workaround:*
Copy '*.so' from 'esf/linuxdlls' to 'esf/dlls'
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top