Linux Server Support/Bug Reports

New Member
Joined
Nov 30, 2002
Messages
1
Best answers
0
This thread can be used primarily to

a) report crashing and other bugs with the linux server
b) obtain support to install the linux server / get it working

I have not been able to play with the server I put up too much, however I have noticed two possible bugs, hopefully I can verify these or someone else can

- The server crashes sometimes when the kamama(sp??) blast is used (I was goku), I think especially if you are firing and get hit and keep the beam going - this seemed to happen a lot on esf_cell_day

- Is gohan's mesnko attack not available for anyone?

Edit: I also noticed the mapcycle.txt was not complete with all the maps available, and one map has a day and night version, but no corresponding bsp maps? If that sounds confusing look at the mapcycle.txt and you'll see esf_cell is not the only one with day and night...?

Please start listing bugs etc you have noticed, perhaps we can come up with reproducable bugs that are common.
 
New Member
Joined
Nov 29, 2002
Messages
492
Best answers
0
I've seen plenty of errors with the linux mod. I hosted it one night and I woke up and it had crashed a few times.

One of them said like this entity error but I'll start using "-debug".

*edit

Oh also the entity error happend right after one of my friends used the kamayamaya blast too. he was also goku.

-pommy

*
 
New Member
Joined
Nov 29, 2002
Messages
492
Best answers
0
I just got this error. Im not sure if its hlds or esf. you decide.

./hlds_run: line 83: 2376 Segmentation fault (core dumped) $HL $*


it keeps doing this constantly now :(
 

Naz

New Member
💻 Oldtimer
Joined
Dec 24, 2001
Messages
1,660
Best answers
0
At gamecity they had 1 crash too, I don't know what the error was, I'll have to ask the server admin
 
Whats that? Paladin in your eye?
Joined
Nov 28, 2001
Messages
679
Best answers
0
Originally posted by Pommy
I just got this error. Im not sure if its hlds or esf. you decide.

./hlds_run: line 83: 2376 Segmentation fault (core dumped) $HL $*


it keeps doing this constantly now :(
Check your system.

sounds like faulty ram :)
 
New Member
Joined
Nov 29, 2002
Messages
492
Best answers
0
Originally posted by Greg
Check your system.

sounds like faulty ram :)
I doubt it. I could try it but the ram is brand new I just upgraded my other machine plus it was working.
 
New Member
Joined
Dec 1, 2002
Messages
9
Best answers
0
I get those exact same seg faults once every hour or two. Its not the system... my NS server is running fine on the same machine.

Here are the last few lines of one of the logs:

L 12/01/2002 - 12:40:47: "HC<60><140891><fatbuu>" killed "AHHHHHHHHHHHHHH<13><1582238><fatbuu>" with "mouthblast"
L 12/01/2002 - 12:40:57: "Flood<40><634347><frieza>" committed suicide with "trigger_hurt" (world)
L 12/01/2002 - 12:40:58: "Raven<61><3258312><goku>" say "how do u block"
L 12/01/2002 - 12:41:04: "TheSkaarj<53><1253823><piccolo>" say "hold q"
L 12/01/2002 - 12:41:08: "Smokey`<47><2892596><trunks>" killed "HC<60><140891><fatbuu>" with "me

As you can see, it stops writing to the log in the middle of the line so the logs have no info. I'll have to get a stack trace for you.
 
New Member
Joined
Nov 29, 2002
Messages
492
Best answers
0
I am offically moving to my windows server until linux is fixed. The linux servers crash and its really annoying. PLEASE FIX!!! I even reinstalled it and still nothing.:talk:
 
New Member
Joined
Dec 1, 2002
Messages
9
Best answers
0
Seems to be the shield attack that is crashing it, everytime someone gets a big one ready it crashes the server.
 
New Member
Joined
Nov 29, 2002
Messages
492
Best answers
0
Do you know why? Because thats true one of my friends was using the shield attack alot.
 
New Member
Joined
Dec 1, 2002
Messages
9
Best answers
0
I have no clue why, but it seems big shield attack = seg faulting server.
 
New Member
Joined
Dec 1, 2002
Messages
9
Best answers
0
The server has crashed 8 times this morning already, the last time something actually appeared in the logs (none of the other crashes have had anything in the logs):

Last 5 lines in hlds_l.log are:
----------------------------------------------------------------------
L 12/02/2002 - 11:59:21: "Cynical<42><184498><cell2>" killed "Jericho<31><720570><vegeta>" with "kamehameha"
L 12/02/2002 - 11:59:22: "Xtr0m3<45><1802057><ssjgoku>" killed "SSJ Herms<43><2509751><vegeta>" with "kamehameha"
L 12/02/2002 - 11:59:23: "Eierbaer mit HaWaZuZi<51><263266><goku>" killed "Ice<38><260802><gohan>" with "Spirit Bomb"
L 12/02/2002 - 11:59:23: FATAL ERROR (shutting down): Bad entity in IndexOfEdict()
FATAL ERROR (shutting down): Bad entity in IndexOfEdict()
----------------------------------------------------------------------
 
New Member
Joined
Nov 29, 2002
Messages
492
Best answers
0
Originally posted by GoleX
The server has crashed 8 times this morning already, the last time something actually appeared in the logs (none of the other crashes have had anything in the logs):

Last 5 lines in hlds_l.log are:
----------------------------------------------------------------------
L 12/02/2002 - 11:59:21: "Cynical<42><184498><cell2>" killed "Jericho<31><720570><vegeta>" with "kamehameha"
L 12/02/2002 - 11:59:22: "Xtr0m3<45><1802057><ssjgoku>" killed "SSJ Herms<43><2509751><vegeta>" with "kamehameha"
L 12/02/2002 - 11:59:23: "Eierbaer mit HaWaZuZi<51><263266><goku>" killed "Ice<38><260802><gohan>" with "Spirit Bomb"
L 12/02/2002 - 11:59:23: FATAL ERROR (shutting down): Bad entity in IndexOfEdict()
FATAL ERROR (shutting down): Bad entity in IndexOfEdict()
----------------------------------------------------------------------
that is the first error I got. They should make a patch and fix the ergent problems that cause games to suck. If your playing for awhile and have a high pl/score you don't want the server to crash.
 
Coder - Harsens sidekick
💻 Oldtimer
Joined
Nov 24, 2001
Messages
1,981
Best answers
0
Hmmm... Well, i recoded my shield about 2 days after release and im pretty sure that i fixed all of the crashing bugs. I'll have to look it more though.
 
New Member
Joined
Nov 29, 2002
Messages
492
Best answers
0
I got a new error. Heres what it says.

SV_StartSound: cell2/specialbeamcannon.wav not precached (0)
SV_StartSound: cell2/specialbeamcannon.wav not precached (0)
SV_StartSound: cell2/specialbeamcannon.wav not precached (0)
SV_StartSound: cell2/specialbeamcannon.wav not precached (0)

then lots of users started dropping but not all of them and then the seg fault error occured again.
 
New Member
Joined
Nov 29, 2002
Messages
492
Best answers
0
nice try. Someone actually came into my house and deleted HLDS so I did have to reinstall and still nothing. Pretty weird case but I'm dead serious. I think it was my brother being a little as$hole.
 
New Member
Joined
Dec 4, 2002
Messages
58
Best answers
0
I found that when really big beams blow up the map seems to obsorb them and make a dome of lag energy around the mad. o_O thx for listening
 

Users who are viewing this thread

Top