LINUX [ESF 123b + evm ] its posible? Dedicated server

New Member
Joined
Jan 19, 2010
Messages
1
Best answers
0
I had been like 5 days trying to find any tutorial about doing this it is posible ? adding EVM or ECX to esf123 on linux?

its posible to add this plugins to host my own dedicated server on linux , thats all ;)
 
Freelance Mappzor
✔️ HL Verified
🚂 Steam Linked
💻 Oldtimer
Joined
Nov 21, 2003
Messages
17,065
Best answers
0
Im afraid a Linux server with ESf 1.2.3 is busted due to a STEAM update a little over a year ago.

Only windows dedicated servers are possible ATM. The issue was resolved in 1.3 though.
 
The Prodigy
★ Black Lounger ★
✔️ HL Verified
🎈 Advanced
Joined
Nov 9, 2002
Messages
676
Best answers
0
It's not impossible to put up a Linux server, Rick got one up.
 
NOT IN THE MANGA™
★ Black Lounger ★
✔️ HL Verified
🚂 Steam Linked
💻 Oldtimer
Joined
Jan 5, 2008
Messages
3,276
Best answers
0
I've managed to make it run on Linux, actually. It was a pain though. Had to get older engine build files (couldn't get Steam ones, so got non-Steam), then to install Metamod with a module that allows Steamed users to connect, then manually block non-Steam, etc.

If anyone gave original Steam files of an older build (like 2738), that might just work.
 
New Member
✔️ HL Verified
💻 Oldtimer
Joined
Mar 29, 2003
Messages
4,765
Best answers
0
But will those Linux servers be VAC secured? Or else you will get hackers and cheaters all over the place.
 
Freelance Mappzor
✔️ HL Verified
🚂 Steam Linked
💻 Oldtimer
Joined
Nov 21, 2003
Messages
17,065
Best answers
0
And will the current version of HL be able to connect to the server with outdated files?
 
NOT IN THE MANGA™
★ Black Lounger ★
✔️ HL Verified
🚂 Steam Linked
💻 Oldtimer
Joined
Jan 5, 2008
Messages
3,276
Best answers
0
We won't know until we try.
 
Freelance Mappzor
✔️ HL Verified
🚂 Steam Linked
💻 Oldtimer
Joined
Nov 21, 2003
Messages
17,065
Best answers
0
Older version means older exe version. Youll get a protocol missmatch error. Unless you can somehow keep the HL version and just revert the steam version.
 
NOT IN THE MANGA™
★ Black Lounger ★
✔️ HL Verified
🚂 Steam Linked
💻 Oldtimer
Joined
Jan 5, 2008
Messages
3,276
Best answers
0
There's a Metamod module that allows clients with 47 and 48 protocol versions to connect. It was meant for non-Steam servers but it could be used in this case too. The worst thing is that there are some non-Steam bots (real bots, LOL), thousands of them (most of them are named EvolutionX, www.duote.com, TuFe.Cn or something like that), and they connect to your server. That's why you need to manually (with a custom plugin, I mean) check if player has protocol 48, if not - kick him out. That really sucks, LOL. Can't remember if VAC-security worked.
 
Last edited:
Freelance Mappzor
✔️ HL Verified
🚂 Steam Linked
💻 Oldtimer
Joined
Nov 21, 2003
Messages
17,065
Best answers
0
Why would bots name themselves after EVM 2.0s full name o_O
 
NOT IN THE MANGA™
★ Black Lounger ★
✔️ HL Verified
🚂 Steam Linked
💻 Oldtimer
Joined
Jan 5, 2008
Messages
3,276
Best answers
0
Someone who created them named them that way.
 

Users who are viewing this thread

Top