Half-Life trouble (new video card)

New Member
Retired Forum Staff
✔️ HL Verified
💻 Oldtimer
Joined
Apr 7, 2003
Messages
1,478
Best answers
0
I recently switched my old ATI 9800XT for a new nvidia 7600GS. I thoroughly removed all the ATI garbage and put in the new card--I got a decent jump in FPS in my games.

But when I start Half-Life (or Half-Life mods, like ESF) I only get like 1-5 FPS. Something is obviously wrong. I tried switching to D3D mode, and it works fine. But in OpenGL mode, whether in original Half-Life or ESF, I get 1-5 FPS.

My other games work fine (WC3, World of Warcraft, Black & White 2, even Half-Life 2-based Vampire the Masquerade: Bloodlines.

I tried tinkering around with the ati_npatch and ati_subdiv console commands, but they didn't change anything. I tried deleting my config file and letting HL rebuild it--no change. Any advice would be appreciated!
 
New Member
💻 Oldtimer
Joined
May 14, 2003
Messages
1,929
Best answers
0
Have you tried any other OpenGL games? All the ones you list working are DX/D3D games (although I don't know if B&W2 is).

Which driver set are you using?
 
New Member
Retired Forum Staff
✔️ HL Verified
💻 Oldtimer
Joined
Apr 7, 2003
Messages
1,478
Best answers
0
I'm using the most current nvidia drivers (I think?), 91.47 forceware. I think one of my screensavers is opengl--haven't had a problem with that.
 
New Member
💻 Oldtimer
Joined
Dec 3, 2002
Messages
2,490
Best answers
0
It may have something to do with Half Life itself. I know there are console commands for some ATI specific things, but clearly that isn't your problem. Have tried enabled vsync or changing your triple buffering settings? It's not as easy on an nvida card but it is possible with some third party help, that will probably do it. For me I had similar problems when my refresh rates weren't optimized and vsynced so maybe you have similar trouble.
 
Lost in space
Banned
💻 Oldtimer
Joined
Dec 21, 2003
Messages
3,608
Best answers
0
In recent times I have heard people report problems with newer nvidia drivers on tech forums I am on, ethier reporting rendering issues in certain games or performance related issues, however it's odd to hear it happen to newer/current nvidia cards.
Pride said:
It may have something to do with Half Life itself. I know there are console commands for some ATI specific things, but clearly that isn't your problem. Have tried enabled vsync or changing your triple buffering settings? It's not as easy on an nvida card but it is possible with some third party help, that will probably do it. For me I had similar problems when my refresh rates weren't optimized and vsynced so maybe you have similar trouble.
Seconded.

I think you should go through to the nvidia control panel and set a profile up for gfx settings for the hl executable or try using a different set of nvidia drivers (Removing you current drivers before you install other drivers of course).
 
New Member
✔️ HL Verified
💻 Oldtimer
Joined
Mar 29, 2003
Messages
4,765
Best answers
0
Ermmm, I currently have the 91.33 drivers, and they seem to work fine with Half Life. Maybe it's a problem with the drivers.
 
New Member
Joined
Jan 7, 2003
Messages
203
Best answers
0
Uninstall Half Life 2, and your drivers.
Check for the latest drivers, Install 'em. Or a viable alternative is to use the Omega drivers, Available at www.guru3d.com.
Check your refresh rates, and verticle sync.
Scan for Adaware and Viruses (Just in case).
Use Alt-Ctrl-Del and check your memory and processor usage on idle. (Good way to tell if your running something intensive that your not aware of).
And if your using a Creative sound card, Update the drivers. (Certain drivers have been known to cause performance issues in Half Life 2).
And Make sure you dont have Anti-Aliasing and what-not on highest possible settings ;)
 
Lost in space
Banned
💻 Oldtimer
Joined
Dec 21, 2003
Messages
3,608
Best answers
0
Pemalite said:
Uninstall Half Life 2, and your drivers.
Check for the latest drivers, Install 'em. Or a viable alternative is to use the Omega drivers, Available at www.guru3d.com.
Check your refresh rates, and verticle sync.
Scan for Adaware and Viruses (Just in case).
Use Alt-Ctrl-Del and check your memory and processor usage on idle. (Good way to tell if your running something intensive that your not aware of).
And if your using a Creative sound card, Update the drivers. (Certain drivers have been known to cause performance issues in Half Life 2).
And Make sure you dont have Anti-Aliasing and what-not on highest possible settings ;)
http://omegadrivers.net

Plus not to mention that the Nvidia side of the Omega drivers have been put on temp hiatus.
 

Users who are viewing this thread

Top